Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. apache-superset
  4. ›
  5. CVE-2023-46104

CVE-2023-46104: Apache Superset uncontrolled resource consumption

December 19, 2023 (updated February 13, 2025)

Uncontrolled resource consumption can be triggered by authenticated attacker that uploads a malicious ZIP to import database, dashboards or datasets. This vulnerability exists in Apache Superset versions up to and including 2.1.2 and versions 3.0.0, 3.0.1.

References

  • github.com/advisories/GHSA-95mg-jgfx-54v9
  • github.com/apache/superset
  • github.com/apache/superset/commit/7c23cb0b3fd224c320b35f05e74b572033569154
  • github.com/apache/superset/commit/f473d13d0d89de5990209ff81b17dfe2cee884d3
  • lists.apache.org/thread/yxbxg4wryb7cb7wyybk11l5nqy0rsrvl
  • nvd.nist.gov/vuln/detail/CVE-2023-46104

Code Behaviors & Features

Detect and mitigate CVE-2023-46104 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.1.2, all versions starting from 3.0.0 before 3.1.0rc1

Fixed versions

  • 2.1.2
  • 3.1.0rc1

Solution

Upgrade to versions 2.1.2, 3.1.0rc1 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-400: Uncontrolled Resource Consumption

Source file

pypi/apache-superset/CVE-2023-46104.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:55 +0000.