Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. apache-superset
  4. ›
  5. CVE-2023-25504

CVE-2023-25504: Apache Superset Server-Side Request Forgery vulnerability

July 6, 2023 (updated February 13, 2025)

A malicious actor who has been authenticated and granted specific permissions in Apache Superset may use the import dataset feature in order to conduct Server-Side Request Forgery attacks and query internal resources on behalf of the server where Superset is deployed. This vulnerability exists in Apache Superset versions up to and including 2.0.1.

References

  • github.com/advisories/GHSA-fxjg-28fm-pfxh
  • github.com/apache/superset
  • lists.apache.org/thread/tdnzkocfsqg2sbbornnp9g492fn4zhtx
  • nvd.nist.gov/vuln/detail/CVE-2023-25504

Code Behaviors & Features

Detect and mitigate CVE-2023-25504 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.1.0

Fixed versions

  • 2.1.0

Solution

Upgrade to version 2.1.0 or above.

Impact 4.9 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-918: Server-Side Request Forgery (SSRF)

Source file

pypi/apache-superset/CVE-2023-25504.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:51 +0000.