Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. apache-superset
  4. ›
  5. CVE-2021-42250

CVE-2021-42250: Improper Encoding or Escaping of Output in Apache Superset

May 24, 2022 (updated November 18, 2024)

Improper output neutralization for Logs. A specific Apache Superset HTTP endpoint allowed for an authenticated user to forge log entries or inject malicious content into logs.

References

  • github.com/advisories/GHSA-5fp8-c45m-256p
  • github.com/apache/superset
  • github.com/pypa/advisory-database/tree/main/vulns/apache-superset/PYSEC-2021-435.yaml
  • lists.apache.org/thread/53lkszw6d3tybp5t99nvgcj538b9trw9
  • nvd.nist.gov/vuln/detail/CVE-2021-42250

Code Behaviors & Features

Detect and mitigate CVE-2021-42250 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.3.2

Fixed versions

  • 1.3.2

Solution

Upgrade to version 1.3.2 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-116: Improper Encoding or Escaping of Output

Source file

pypi/apache-superset/CVE-2021-42250.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:58 +0000.