Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. apache-dolphinscheduler
  4. ›
  5. CVE-2022-25598

CVE-2022-25598: Uncontrolled Resource Consumption

March 31, 2022 (updated May 22, 2022)

Apache DolphinScheduler user registration is vulnerable to Regular express Denial of Service (ReDoS) attacks, Apache DolphinScheduler users should upgrade to version 2.0.5 or higher.

References

  • github.com/advisories/GHSA-qg5x-66hp-cw5p
  • github.com/pypa/advisory-database/tree/main/vulns/apache-dolphinscheduler/PYSEC-2022-176.yaml
  • lists.apache.org/thread/hwnw7xr969sg5nv84wz75nfr2c76fl93
  • nvd.nist.gov/vuln/detail/CVE-2022-25598

Code Behaviors & Features

Detect and mitigate CVE-2022-25598 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 0 before 2.0.5

Fixed versions

  • 2.0.5

Solution

Upgrade to version 2.0.5 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-400: Uncontrolled Resource Consumption

Source file

pypi/apache-dolphinscheduler/CVE-2022-25598.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:37 +0000.