Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. apache-airflow
  4. ›
  5. CVE-2024-39863

CVE-2024-39863: Apache Airflow Potential Cross-site Scripting Vulnerability

July 17, 2024 (updated January 21, 2025)

Apache Airflow versions before 2.9.3 have a vulnerability that allows an authenticated attacker to inject a malicious link when installing a provider. Users are recommended to upgrade to version 2.9.3, which fixes this issue.

References

  • github.com/advisories/GHSA-j482-47xf-p25c
  • github.com/apache/airflow
  • github.com/apache/airflow/commit/f18f48492dc69f392e45567580b6ddb0c070ea58
  • github.com/apache/airflow/pull/40475
  • github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2024-189.yaml
  • lists.apache.org/thread/gxkvs279f1mbvckv5q65worr6how20o3
  • nvd.nist.gov/vuln/detail/CVE-2024-39863

Code Behaviors & Features

Detect and mitigate CVE-2024-39863 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.9.3

Fixed versions

  • 2.9.3

Solution

Upgrade to version 2.9.3 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-74: Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection')
  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

pypi/apache-airflow/CVE-2024-39863.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:16 +0000.