Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. apache-airflow
  4. ›
  5. CVE-2024-32077

CVE-2024-32077: Apache Airflow: XSS vulnerability in Task Instance Log/Log Details

May 14, 2024 (updated June 5, 2026)

Apache Airflow version 2.9.0 has a vulnerability that allows an authenticated attacker to inject malicious data into the task instance logs. Users are recommended to upgrade to version 2.9.1, which fixes this issue.

References

  • github.com/advisories/GHSA-52gm-qmg3-r4qp
  • github.com/apache/airflow/commit/87acf61f574daf47ce9e03a986e352a2c727f4ce
  • github.com/apache/airflow/pull/38882
  • github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2024-264.yaml
  • lists.apache.org/thread/gsjmnrqb3m5fzp0vgpty1jxcywo91v77
  • nvd.nist.gov/vuln/detail/CVE-2024-32077

Code Behaviors & Features

Detect and mitigate CVE-2024-32077 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.9.0 before 2.9.1

Fixed versions

  • 2.9.1

Solution

Upgrade to version 2.9.1 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

pypi/apache-airflow/CVE-2024-32077.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:41 +0000.