Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. apache-airflow
  4. ›
  5. CVE-2023-50783

CVE-2023-50783: Apache Airflow Improper Access Control vulnerability

December 21, 2023 (updated November 21, 2024)

Apache Airflow, versions before 2.8.0, is affected by a vulnerability that allows an authenticated user without the variable edit permission, to update a variable. This flaw compromises the integrity of variable management, potentially leading to unauthorized data modification. Users are recommended to upgrade to 2.8.0, which fixes this issue.

References

  • github.com/advisories/GHSA-5938-79hg-xh3q
  • github.com/apache/airflow
  • github.com/apache/airflow/commit/0e1c106d7cd0703125528a691088e42e17c99929
  • github.com/apache/airflow/pull/33932
  • github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2023-267.yaml
  • lists.apache.org/thread/rs7cr3yp726mb89s1m844hy9pq7frgcn
  • nvd.nist.gov/vuln/detail/CVE-2023-50783

Code Behaviors & Features

Detect and mitigate CVE-2023-50783 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.8.0

Fixed versions

  • 2.8.0

Solution

Upgrade to version 2.8.0 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-284: Improper Access Control

Source file

pypi/apache-airflow/CVE-2023-50783.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:01 +0000.