Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. apache-airflow
  4. ›
  5. CVE-2023-45348

CVE-2023-45348: Exposure of Sensitive Information to an Unauthorized Actor

October 14, 2023 (updated November 16, 2023)

Apache Airflow, versions 2.7.0 and 2.7.1, is affected by a vulnerability that allows an authenticated user to retrieve sensitive configuration information when the “expose_config” option is set to “non-sensitive-only”. The expose_config option is False by default. It is recommended to upgrade to a version that is not affected.

References

  • github.com/advisories/GHSA-fpxx-xv4c-gxqp
  • github.com/apache/airflow/pull/34712
  • lists.apache.org/thread/sy4l5d6tn58hr8r61r2fkt1f0qock9z9
  • nvd.nist.gov/vuln/detail/CVE-2023-45348

Code Behaviors & Features

Detect and mitigate CVE-2023-45348 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.7.0 before 2.7.2

Fixed versions

  • 2.7.2

Solution

Upgrade to version 2.7.2 or above.

Impact 4.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Learn more about CVSS

Source file

pypi/apache-airflow/CVE-2023-45348.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:43 +0000.