Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. apache-airflow
  4. ›
  5. CVE-2023-42781

CVE-2023-42781: Apache Airflow vulnerable to Exposure of Sensitive Information to an Unauthorized Actor

November 12, 2023 (updated November 18, 2024)

Apache Airflow, versions before 2.7.3, has a vulnerability that allows an authorized user who has access to read specific DAGs only, to read information about task instances in other DAGs.  This is a different issue than CVE-2023-42663 but leading to similar outcome. Users of Apache Airflow are advised to upgrade to version 2.7.3 or newer to mitigate the risk associated with this vulnerability.

References

  • github.com/advisories/GHSA-r7x6-xfcm-3mxv
  • github.com/apache/airflow
  • github.com/apache/airflow/commit/33ec72948f74f56f2adb5e2d388e60e88e8a3fa3
  • github.com/apache/airflow/pull/34939
  • github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2023-231.yaml
  • lists.apache.org/thread/7dnl8nszdxqyns57f3dw0sloy5dfl9o1
  • nvd.nist.gov/vuln/detail/CVE-2023-42781

Code Behaviors & Features

Detect and mitigate CVE-2023-42781 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.7.3

Fixed versions

  • 2.7.3

Solution

Upgrade to version 2.7.3 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-200: Exposure of Sensitive Information to an Unauthorized Actor

Source file

pypi/apache-airflow/CVE-2023-42781.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:23 +0000.