Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. apache-airflow
  4. ›
  5. CVE-2023-36543

CVE-2023-36543: Apache Airflow Improper Input Validation vulnerability

July 12, 2023 (updated November 18, 2024)

Apache Airflow, versions before 2.6.3, has a vulnerability where an authenticated user can use crafted input to make the current request hang. It is recommended to upgrade to a version that is not affected

References

  • github.com/advisories/GHSA-3h4m-m55v-gx4m
  • github.com/apache/airflow
  • github.com/apache/airflow/commit/116e607ddcb32480e57c342f48226545ac6fc315
  • github.com/apache/airflow/pull/32060
  • github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2023-106.yaml
  • lists.apache.org/thread/tokfs980504ylgk3cv3hjlnrtbv4tng4
  • nvd.nist.gov/vuln/detail/CVE-2023-36543

Code Behaviors & Features

Detect and mitigate CVE-2023-36543 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.6.3

Fixed versions

  • 2.6.3

Solution

Upgrade to version 2.6.3 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-1333: Inefficient Regular Expression Complexity
  • CWE-20: Improper Input Validation

Source file

pypi/apache-airflow/CVE-2023-36543.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:34 +0000.