Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. apache-airflow
  4. ›
  5. CVE-2023-35908

CVE-2023-35908: Apache Airflow Incorrect Authorization vulnerability

July 12, 2023 (updated November 18, 2024)

Apache Airflow, versions before 2.6.3, is affected by a vulnerability that allows unauthorized read access to a DAG through the URL. It is recommended to upgrade to a version that is not affected

References

  • github.com/advisories/GHSA-2h84-3crq-vgfj
  • github.com/apache/airflow
  • github.com/apache/airflow/commit/ac65b82eeeeaa670e09a83c7da65cbac7e89f8db
  • github.com/apache/airflow/commit/c78e16588ee399f6eaf60425eb1ad7fa6d3fe352
  • github.com/apache/airflow/pull/32014
  • github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2023-119.yaml
  • lists.apache.org/thread/vsflptk5dt30vrfggn96nx87d7zr6yvw
  • nvd.nist.gov/vuln/detail/CVE-2023-35908

Code Behaviors & Features

Detect and mitigate CVE-2023-35908 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.6.3

Fixed versions

  • 2.6.3

Solution

Upgrade to version 2.6.3 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-863: Incorrect Authorization

Source file

pypi/apache-airflow/CVE-2023-35908.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:12 +0000.