Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. apache-airflow
  4. ›
  5. CVE-2023-22888

CVE-2023-22888: Apache Airflow Improper Input Validation vulnerability

July 12, 2023 (updated November 18, 2024)

Apache Airflow, versions before 2.6.3, is affected by a vulnerability that allows an attacker to cause a service disruption by manipulating the run_id parameter. This vulnerability is considered low since it requires an authenticated user to exploit it. It is recommended to upgrade to a version that is not affected

References

  • github.com/advisories/GHSA-5946-8p38-vffp
  • github.com/apache/airflow
  • github.com/apache/airflow/commit/05bd90f563649f2e9c8f0c85cf5838315a665a02
  • github.com/apache/airflow/pull/32293
  • github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2023-105.yaml
  • lists.apache.org/thread/dnlht2hvm7k81k5tgjtsfmk27c76kq7z
  • nvd.nist.gov/vuln/detail/CVE-2023-22888

Code Behaviors & Features

Detect and mitigate CVE-2023-22888 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.6.3

Fixed versions

  • 2.6.3

Solution

Upgrade to version 2.6.3 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

pypi/apache-airflow/CVE-2023-22888.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:43 +0000.