Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. apache-airflow
  4. ›
  5. CVE-2020-17526

CVE-2020-17526: Incorrect Session Validation in Apache Airflow

April 20, 2021 (updated September 11, 2024)

Incorrect Session Validation in Apache Airflow Webserver versions prior to 1.10.14 with default config allows a malicious airflow user on site A where they log in normally, to access unauthorized Airflow Webserver on Site B through the session from Site A. This does not affect users who have changed the default value for [webserver] secret_key config.

References

  • github.com/advisories/GHSA-7mx5-x372-xh87
  • github.com/apache/airflow
  • github.com/apache/airflow/commit/2f3b1c780472afd4c8a93633e6633feb7083792e
  • github.com/apache/airflow/commit/6b065840323f9a4fc8e372b458d26e419e4fa99b
  • github.com/apache/airflow/commit/97b2735d65e95c4633966667b6db3908540f3937
  • github.com/apache/airflow/commit/9e01476a50b9be27c4b1e6c6e24d36f290629195
  • github.com/apache/airflow/commit/a8900fa5f2b8963e9f57ba4ae5520a5d339aeaad
  • github.com/apache/airflow/commit/dfa7b26ddaca80ee8fd9915ee9f6eac50fac77f6
  • github.com/apache/airflow/commit/fe6d00a54f83468e296777d3b83b65a2ae7169ec
  • github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2020-22.yaml
  • lists.apache.org/thread.html/r466759f377651f0a690475d5a52564d0e786e82c08d5a5730a4f8352@%3Cannounce.apache.org%3E
  • lists.apache.org/thread.html/rbeeb73a6c741f2f9200d83b9c2220610da314810c4e8c9cf881d47ef%40%3Cusers.airflow.apache.org%3E
  • nvd.nist.gov/vuln/detail/CVE-2020-17526

Code Behaviors & Features

Detect and mitigate CVE-2020-17526 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.10.14

Fixed versions

  • 1.10.14

Solution

Upgrade to version 1.10.14 or above.

Impact 7.7 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-269: Improper Privilege Management

Source file

pypi/apache-airflow/CVE-2020-17526.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:30 +0000.