Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. apache-airflow
  4. ›
  5. CVE-2019-0229

CVE-2019-0229: Apache Airflow vulnerable to CSRF Attacks

April 18, 2019 (updated September 12, 2024)

A number of HTTP endpoints in the Airflow webserver (both RBAC and classic) did not have adequate protection and were vulnerable to cross-site request forgery attacks.

References

  • github.com/advisories/GHSA-w6j4-3gh2-9f5j
  • github.com/apache/airflow
  • github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2019-215.yaml
  • lists.apache.org/thread.html/2de387213d45bc626d27554a1bde7b8c67d08720901f82a50b6f4231@%3Cdev.airflow.apache.org%3E
  • nvd.nist.gov/vuln/detail/CVE-2019-0229
  • web.archive.org/web/20200227081055/http://www.securityfocus.com/bid/107869

Code Behaviors & Features

Detect and mitigate CVE-2019-0229 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.10.3

Fixed versions

  • 1.10.3

Solution

Upgrade to version 1.10.3 or above.

Impact 8.8 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-352: Cross-Site Request Forgery (CSRF)

Source file

pypi/apache-airflow/CVE-2019-0229.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:56 +0000.