Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. apache-airflow
  4. ›
  5. CVE-2018-20244

CVE-2018-20244: Apache Airflow vulnerable to Stored XSS

March 6, 2019 (updated September 10, 2024)

In Apache Airflow before 1.10.2, a malicious admin user could edit the state of objects in the Airflow metadata database to execute arbitrary javascript on certain page views.

References

  • github.com/advisories/GHSA-99cv-8cvv-666c
  • github.com/apache/airflow
  • github.com/apache/airflow/commit/27a4a888e946728d9bb33b78ec604e08d4a93f89
  • github.com/apache/airflow/commit/3ff94c7da60fbb24bf99eb6192c7386e8ab4c4c9
  • github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2019-142.yaml
  • lists.apache.org/thread.html/2de387213d45bc626d27554a1bde7b8c67d08720901f82a50b6f4231@%3Cdev.airflow.apache.org%3E
  • lists.apache.org/thread.html/f656fddf9c49293b3ec450437c46709eb01a12d1645136b2f1b8573b@%3Cdev.airflow.apache.org%3E
  • nvd.nist.gov/vuln/detail/CVE-2018-20244

Code Behaviors & Features

Detect and mitigate CVE-2018-20244 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.10.2

Fixed versions

  • 1.10.2

Solution

Upgrade to version 1.10.2 or above.

Impact 5.5 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

pypi/apache-airflow/CVE-2018-20244.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:56 +0000.