Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. apache-airflow
  4. ›
  5. CVE-2017-15720

CVE-2017-15720: Improper Input Validation

January 23, 2019 (updated January 25, 2019)

In Apache Airflow, an authenticated user can execute code remotely on the Airflow webserver by creating a special object.

References

  • nvd.nist.gov/vuln/detail/CVE-2017-15720

Code Behaviors & Features

Detect and mitigate CVE-2017-15720 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 1.8.2

Fixed versions

  • 1.9.0

Solution

Upgrade to version 1.9.0 or above.

Impact 8.8 HIGH

CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

pypi/apache-airflow/CVE-2017-15720.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:05 +0000.