Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. apache-airflow-providers-mongo
  4. ›
  5. CVE-2024-25141

CVE-2024-25141: Improper Certificate Validation in apache airflow mongo hook

February 20, 2024 (updated October 26, 2026)

When ssl was enabled for Mongo Hook, default settings included “allow_insecure” which caused that certificates were not validated. This was unexpected and undocumented. Users are recommended to upgrade to version 4.0.0, which fixes this issue.

References

  • github.com/advisories/GHSA-x5pm-h33q-cjrw
  • github.com/apache/airflow/pull/37214
  • github.com/pypa/advisory-database/tree/main/vulns/apache-airflow-providers-mongo/PYSEC-2026-278.yaml
  • lists.apache.org/thread/sqgbfqngjmn45ommmrgj7hvs7fgspsgm
  • nvd.nist.gov/vuln/detail/CVE-2024-25141
  • pypi.org/project/apache-airflow-providers-mongo

Code Behaviors & Features

Detect and mitigate CVE-2024-25141 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.0.0

Fixed versions

  • 4.0.0

Solution

Upgrade to version 4.0.0 or above.

Impact 9.1 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-295: Improper Certificate Validation

Source file

pypi/apache-airflow-providers-mongo/CVE-2024-25141.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:41 +0000.