Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. apache-airflow-providers-google
  4. ›
  5. CVE-2023-25692

CVE-2023-25692: Improper Input Validation

February 24, 2023

Improper Input Validation vulnerability in the Apache Airflow Google Provider. This issue affects Apache Airflow Google Provider versions before 8.10.0.

References

  • github.com/advisories/GHSA-h8p2-8g72-qpgh
  • github.com/apache/airflow/pull/29499
  • lists.apache.org/thread/ks4l78l5rwdpmvfn7y7yhs179nyxtlsh
  • nvd.nist.gov/vuln/detail/CVE-2023-25692

Code Behaviors & Features

Detect and mitigate CVE-2023-25692 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 8.10.0

Fixed versions

  • 8.10.0

Solution

Upgrade to version 8.10.0 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

pypi/apache-airflow-providers-google/CVE-2023-25692.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:30 +0000.