Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. apache-airflow-providers-google
  4. ›
  5. CVE-2023-25691

CVE-2023-25691: Apache Airflow Google Provider Improper Input Validation vulnerability

February 24, 2023 (updated October 26, 2026)

Improper Input Validation vulnerability in the Apache Airflow Google Provider. This issue affects Apache Airflow Google Provider versions before 8.10.0.

References

  • github.com/advisories/GHSA-8g23-2q5p-8866
  • github.com/apache/airflow/pull/29497
  • github.com/pypa/advisory-database/tree/main/vulns/apache-airflow-providers-google/PYSEC-2026-277.yaml
  • lists.apache.org/thread/zdr8ovfttbh7kj0lydgcw88tbt2nmkcy
  • nvd.nist.gov/vuln/detail/CVE-2023-25691
  • pypi.org/project/apache-airflow-providers-google

Code Behaviors & Features

Detect and mitigate CVE-2023-25691 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 8.10.0

Fixed versions

  • 8.10.0

Solution

Upgrade to version 8.10.0 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

pypi/apache-airflow-providers-google/CVE-2023-25691.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:50 +0000.