Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. apache-airflow-providers-apache-spark
  4. ›
  5. CVE-2023-28710

CVE-2023-28710: Improper Input Validation

April 7, 2023 (updated May 22, 2023)

Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow Spark Provider.This issue affects Apache Airflow Spark Provider: before 4.0.1.

References

  • www.openwall.com/lists/oss-security/2023/04/07/3
  • github.com/advisories/GHSA-ffj9-4crc-q7wf
  • github.com/apache/airflow/pull/30223
  • lists.apache.org/thread/lb9w9114ow00h2nkn8bjm106v5x1p1d2
  • nvd.nist.gov/vuln/detail/CVE-2023-28710

Code Behaviors & Features

Detect and mitigate CVE-2023-28710 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.0.1

Fixed versions

  • 4.0.1

Solution

Upgrade to version 4.0.1 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

pypi/apache-airflow-providers-apache-spark/CVE-2023-28710.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:00 +0000.