Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. apache-airflow-providers-apache-hive
  4. ›
  5. CVE-2022-46421

CVE-2022-46421: Apache Airflow Hive Provider vulnerable to Command Injection

December 20, 2022 (updated October 26, 2026)

Improper Neutralization of Special Elements used in a Command (‘Command Injection’) vulnerability in Apache Software Foundation Apache Airflow Hive Provider.This issue affects Apache Airflow Hive Provider before 5.0.0.

References

  • github.com/advisories/GHSA-rc58-qr9j-cpgw
  • github.com/apache/airflow/pull/28101
  • github.com/pypa/advisory-database/tree/main/vulns/apache-airflow-providers-apache-hive/PYSEC-2026-274.yaml
  • lists.apache.org/thread/09twdoyoybldlfj5gvk0qswtofh0rmp4
  • nvd.nist.gov/vuln/detail/CVE-2022-46421
  • pypi.org/project/apache-airflow-providers-apache-hive

Code Behaviors & Features

Detect and mitigate CVE-2022-46421 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 5.0.0

Fixed versions

  • 5.0.0

Solution

Upgrade to version 5.0.0 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-77: Improper Neutralization of Special Elements used in a Command ('Command Injection')

Source file

pypi/apache-airflow-providers-apache-hive/CVE-2022-46421.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:36 +0000.