Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. apache-airflow-core
  4. ›
  5. CVE-2026-49298

CVE-2026-49298: Apache Airflow: Execution API JWT leaked via KubernetesExecutor worker command-line args

June 1, 2026 (updated July 8, 2026)

A bug in Apache Airflow’s KubernetesExecutor caused JWT tokens used by worker pods to authenticate against the Execution API to be passed to the worker container as command-line arguments visible in the pod spec. An authenticated UI/API user with Kubernetes read-only access to the cluster (e.g. pods/get in the Airflow namespace) could harvest the JWT from kubectl describe pod output and then call state-mutating Execution API endpoints — triggering Dag runs, clearing runs, reading or writing Variables / Connections / XComs — as if they were a running task. Affects deployments using the KubernetesExecutor. Users are advised to upgrade to apache-airflow 3.2.2 or later. This is the airflow-core half of the same vulnerability addressed by CVE-2026-27173, which shipped the apache-airflow-providers-cncf-kubernetes side of the fix. Deployments that already upgraded apache-airflow-providers-cncf-kubernetes to 10.17.0 or later per the CVE-2026-27173 advisory should additionally upgrade apache-airflow to 3.2.2 or later to close the core-side surface — the two fixes are complementary, not duplicates.

References

  • github.com/advisories/GHSA-5j6p-jrrm-6x94
  • github.com/apache/airflow/pull/60108
  • lists.apache.org/thread/wo09vrks8189dzsot39rvrx3vnx102tt
  • nvd.nist.gov/vuln/detail/CVE-2026-49298

Code Behaviors & Features

Detect and mitigate CVE-2026-49298 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.2.2

Fixed versions

  • 3.2.2

Solution

Upgrade to version 3.2.2 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-538: Insertion of Sensitive Information into Externally-Accessible File or Directory

Source file

pypi/apache-airflow-core/CVE-2026-49298.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:31 +0000.