Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. ansibleguy-webui
  4. ›
  5. CVE-2024-36110

CVE-2024-36110: ansibleguy-webui Cross-site Scripting vulnerability

May 28, 2024

Multiple forms in version <0.0.21 allowed injection of HTML elements. These are returned to the user after executing job actions and thus evaluated by the browser.

References

  • github.com/advisories/GHSA-927p-xrc2-x2gj
  • github.com/ansibleguy/webui
  • github.com/ansibleguy/webui/commit/7737b47e7f7ddbfec7b1418c724598363718d522
  • github.com/ansibleguy/webui/files/15358522/Report.pdf
  • github.com/ansibleguy/webui/security/advisories/GHSA-927p-xrc2-x2gj
  • nvd.nist.gov/vuln/detail/CVE-2024-36110

Code Behaviors & Features

Detect and mitigate CVE-2024-36110 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.0.21

Fixed versions

  • 0.0.21

Solution

Upgrade to version 0.0.21 or above.

Impact 8.2 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:L

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

pypi/ansibleguy-webui/CVE-2024-36110.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:52 +0000.