Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. ansible
  4. ›
  5. CVE-2021-20228

CVE-2021-20228: Information Exposure

April 29, 2021 (updated November 7, 2023)

A flaw was found in the Ansible Engine, where sensitive info is not masked by default and is not protected by the no_log feature when using the sub-option feature of the basic.py module. This flaw allows an attacker to obtain sensitive information. The highest threat from this vulnerability is to confidentiality.

References

  • bugzilla.redhat.com/show_bug.cgi?id=1925002
  • nvd.nist.gov/vuln/detail/CVE-2021-20228

Code Behaviors & Features

Detect and mitigate CVE-2021-20228 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

Version 2.0, version 2.9, version 2.9.18

Fixed versions

  • 2.0.0.1
  • 2.9.1
  • 2.9.19

Solution

Upgrade to versions 2.0.0.1, 2.9.1, 2.9.19 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-200: Exposure of Sensitive Information to an Unauthorized Actor

Source file

pypi/ansible/CVE-2021-20228.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:15 +0000.