Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. ansible
  4. ›
  5. CVE-2020-1738

CVE-2020-1738: Argument Injection or Modification

March 16, 2020 (updated August 4, 2021)

A flaw was found in Ansible Engine when the module package or service is used and the parameter use is not specified. If a previous task is executed with a malicious user, the module sent can be selected by the attacker using the ansible facts file.

References

  • bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-1738
  • nvd.nist.gov/vuln/detail/CVE-2020-1738

Code Behaviors & Features

Detect and mitigate CVE-2020-1738 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 2.7.16, all versions starting from 2.8.0 up to 2.8.8, all versions starting from 2.9.0 up to 2.9.5

Fixed versions

  • 2.7.17
  • 2.8.9
  • 2.9.6

Solution

Upgrade to versions 2.7.17, 2.8.9, 2.9.6 or above.

Impact 3.9 LOW

CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:N/I:L/A:L

Learn more about CVSS

Weakness

  • CWE-88: Improper Neutralization of Argument Delimiters in a Command ('Argument Injection')

Source file

pypi/ansible/CVE-2020-1738.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:17 +0000.