Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. ansible
  4. ›
  5. CVE-2020-10684

CVE-2020-10684: Code Injection, Race Condition, and Execution with Unnecessary Privileges in Ansible

April 7, 2021 (updated November 18, 2024)

A flaw was found in Ansible Engine, all versions 2.7.x, 2.8.x and 2.9.x prior to 2.7.17, 2.8.11, and 2.9.7 respectively, when using ansible_facts as a subkey of itself and promoting it to a variable when inject is enabled, overwriting the ansible_facts after the clean. An attacker could take advantage of this by altering the ansible_facts, such as ansible_hosts, users and any other key data which would lead into privilege escalation or code injection.

References

  • bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-10684
  • github.com/advisories/GHSA-p62g-jhg6-v3rq
  • github.com/ansible/ansible
  • github.com/ansible/ansible/commit/0b4788a71fc7d24ffa957a94ee5e23d6a9733ab0
  • github.com/ansible/ansible/commit/1d0d2645eed36ac4e17052ab4eacf240132d96fb
  • github.com/ansible/ansible/commit/5eabf7bb93c9bfc375b806a2b1f623d650cddc2b
  • github.com/ansible/ansible/commit/a9d2ceafe429171c0e2ad007058b88bae57c74ce
  • github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2020-207.yaml
  • lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/DKPA4KC3OJSUFASUYMG66HKJE7ADNGFW
  • lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/MRRYUU5ZBLPBXCYG6CFP35D64NP2UB2S
  • lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/WQVOQD4VAIXXTVQAJKTN7NUGTJFE2PCB
  • nvd.nist.gov/vuln/detail/CVE-2020-10684
  • security.gentoo.org/glsa/202006-11
  • www.debian.org/security/2021/dsa-4950

Code Behaviors & Features

Detect and mitigate CVE-2020-10684 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.7.0a1 before 2.7.17, all versions starting from 2.8.0a1 before 2.8.11, all versions starting from 2.9.0a1 before 2.9.7

Fixed versions

  • 2.7.17
  • 2.8.11
  • 2.9.7

Solution

Upgrade to versions 2.7.17, 2.8.11, 2.9.7 or above.

Impact 7.1 HIGH

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-250: Execution with Unnecessary Privileges
  • CWE-362: Concurrent Execution using Shared Resource with Improper Synchronization ('Race Condition')
  • CWE-862: Missing Authorization
  • CWE-94: Improper Control of Generation of Code ('Code Injection')

Source file

pypi/ansible/CVE-2020-10684.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:47 +0000.