Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. ansible
  4. ›
  5. CVE-2018-10874

CVE-2018-10874: Improper Input Validation

July 2, 2018 (updated July 25, 2019)

In ansible it was found that inventory variables are loaded from current working directory when running ad-hoc command which are under attacker’s control. The attacker can run arbitrary code as a result.

References

  • www.securitytracker.com/id/1041396
  • bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10874
  • nvd.nist.gov/vuln/detail/CVE-2018-10874

Code Behaviors & Features

Detect and mitigate CVE-2018-10874 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

Version 2.0, all versions starting from 2.4 up to 2.6

Fixed versions

  • 2.0.0.1
  • 2.6.1

Solution

Upgrade to versions 2.0.0.1, 2.6.1 or above.

Impact 7.8 HIGH

CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

pypi/ansible/CVE-2018-10874.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:26 +0000.