Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. ansible
  4. ›
  5. CVE-2017-2809

CVE-2017-2809: Improper Control of Generation of Code

July 13, 2018 (updated September 8, 2021)

An exploitable vulnerability exists in the yaml loading functionality of ansible-vault before 1.0.5. A specially crafted vault can execute arbitrary python commands resulting in command execution. An attacker can insert python into the vault to trigger this vulnerability.

References

  • www.securityfocus.com/bid/100824
  • github.com/advisories/GHSA-c2w9-48qc-qpj4
  • github.com/tomoh1r/ansible-vault/blob/v1.0.5/CHANGES.txt
  • github.com/tomoh1r/ansible-vault/commit/3f8f659ef443ab870bb19f95d43543470168ae04
  • github.com/tomoh1r/ansible-vault/issues/4
  • nvd.nist.gov/vuln/detail/CVE-2017-2809
  • www.talosintelligence.com/vulnerability_reports/TALOS-2017-0305

Code Behaviors & Features

Detect and mitigate CVE-2017-2809 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.0.5

Fixed versions

  • 1.0.5

Solution

Upgrade to version 1.0.5 or above.

Impact 7.8 HIGH

CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-78: Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')
  • CWE-94: Improper Control of Generation of Code ('Code Injection')

Source file

pypi/ansible/CVE-2017-2809.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:18 +0000.