Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. ansible
  4. ›
  5. CVE-2016-8647

CVE-2016-8647: Improper Input Validation

July 26, 2018 (updated October 9, 2019)

An input validation vulnerability was found in Ansible’s mysql_user module, which may fail to correctly change a password in certain circumstances. Thus, the previous password would still be active when it should have been changed.

References

  • access.redhat.com/errata/RHSA-2017:1685
  • bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-8647
  • nvd.nist.gov/vuln/detail/CVE-2016-8647

Code Behaviors & Features

Detect and mitigate CVE-2016-8647 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.2.1.0

Fixed versions

  • 2.2.1.0

Solution

Upgrade to version 2.2.1.0 or above.

Impact 4.9 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

pypi/ansible/CVE-2016-8647.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:52 +0000.