Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. ansible
  4. ›
  5. CVE-2016-3096

CVE-2016-3096: Improper Link Resolution Before File Access

October 10, 2018 (updated September 17, 2021)

The create_script function in the lxc_container module in Ansible before 1.9.6-1 and 2.x before 2.0.2.0 allows local users to write to arbitrary files or gain privileges via a symlink attack on the archived container in the archive_path directory, or the lxc-attach-script.err files in the temporary directory.

References

  • github.com/advisories/GHSA-rh6x-qvg7-rrmj
  • nvd.nist.gov/vuln/detail/CVE-2016-3096

Code Behaviors & Features

Detect and mitigate CVE-2016-3096 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.0.0 up to 2.0.1.0, all versions up to 1.9.6.0

Fixed versions

  • 1.9.6.1

Solution

Upgrade to version 1.9.6.1 or above.

Impact 7.8 HIGH

CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-59: Improper Link Resolution Before File Access ('Link Following')

Source file

pypi/ansible/CVE-2016-3096.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:09 +0000.