Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. ansible
  4. ›
  5. CVE-2014-4658

CVE-2014-4658: Security fix for vault

February 20, 2020 (updated February 25, 2020)

The vault subsystem in Ansible does not set the umask before creation or modification of a vault file, which allows local users to obtain sensitive key information by reading a file.

References

  • github.com/ansible/ansible/blob/release1.5.5/CHANGELOG.md
  • github.com/ansible/ansible/commit/a0e027fe362fbc209dbeff2f72d6e95f39885c69
  • nvd.nist.gov/vuln/detail/CVE-2014-4658
  • www.securityfocus.com/bid/68233

Code Behaviors & Features

Detect and mitigate CVE-2014-4658 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.5.5

Fixed versions

  • 1.5.5

Solution

Upgrade to version 1.5.5 or above.

Impact 5.5 MEDIUM

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-200: Exposure of Sensitive Information to an Unauthorized Actor

Source file

pypi/ansible/CVE-2014-4658.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:11 +0000.