Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. ansible
  4. ›
  5. CVE-2014-4657

CVE-2014-4657: Security fix for safe_eval

February 20, 2020 (updated February 25, 2020)

The safe_eval function in Ansible does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions.

References

  • github.com/ansible/ansible/blob/release1.5.5/CHANGELOG.md
  • github.com/ansible/ansible/commit/998793fd0ab55705d57527a38cee5e83f535974c
  • nvd.nist.gov/vuln/detail/CVE-2014-4657
  • www.securityfocus.com/bid/68232

Code Behaviors & Features

Detect and mitigate CVE-2014-4657 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.5.4

Fixed versions

  • 1.5.4

Solution

Upgrade to version 1.5.4 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

pypi/ansible/CVE-2014-4657.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:45 +0000.