Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. ansible
  4. ›
  5. CVE-2014-3498

CVE-2014-3498: Improper Input Validation

May 14, 2022 (updated August 16, 2023)

The user module in ansible before 1.6.6 allows remote authenticated users to execute arbitrary commands.

References

  • bugzilla.redhat.com/show_bug.cgi?id=1335551
  • github.com/advisories/GHSA-4cvm-5776-jx9f
  • github.com/ansible/ansible/commit/8ed6350e65c82292a631f08845dfaacffe7f07f5
  • nvd.nist.gov/vuln/detail/CVE-2014-3498

Code Behaviors & Features

Detect and mitigate CVE-2014-3498 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.6.6

Fixed versions

  • 1.6.6

Solution

Upgrade to version 1.6.6 or above.

Impact 8.8 HIGH

CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation
  • CWE-78: Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')

Source file

pypi/ansible/CVE-2014-3498.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:20 +0000.