Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. ansible
  4. ›
  5. CVE-2013-4260

CVE-2013-4260: Ansible Arbitrary File Overwrite Vulnerability

May 14, 2022 (updated August 28, 2023)

lib/ansible/playbook/init.py in Ansible 1.2.x before 1.2.3, when playbook does not run due to an error, allows local users to overwrite arbitrary files via a symlink attack on a retry file with a predictable name in /var/tmp/ansible/.

References

  • www.ansible.com/security
  • bugzilla.redhat.com/show_bug.cgi?id=998227
  • exchange.xforce.ibmcloud.com/vulnerabilities/86898
  • github.com/advisories/GHSA-pcqv-c46v-2p4v
  • github.com/ansible/ansible/commit/ed3e4aff84fb32005d8e91dbf0fd7b134a482486
  • groups.google.com/forum/
  • groups.google.com/forum/
  • nvd.nist.gov/vuln/detail/CVE-2013-4260

Code Behaviors & Features

Detect and mitigate CVE-2013-4260 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 1.2 before 1.3.0

Fixed versions

  • 1.3.0

Solution

Upgrade to version 1.3.0 or above.

Impact 3.3 LOW

AV:L/AC:M/Au:N/C:N/I:P/A:P

Learn more about CVSS

Weakness

  • CWE-264

Source file

pypi/ansible/CVE-2013-4260.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:43 +0000.