Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. ansible-vault
  4. ›
  5. CVE-2017-2809

CVE-2017-2809: Code Injection

September 14, 2017 (updated October 2, 2017)

An exploitable vulnerability exists in the yaml loading functionality of ansible-vault. A specially crafted vault can execute arbitrary python commands resulting in command execution. An attacker can insert python into the vault to trigger this vulnerability.

References

  • www.securityfocus.com/bid/100824
  • nvd.nist.gov/vuln/detail/CVE-2017-2809

Code Behaviors & Features

Detect and mitigate CVE-2017-2809 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 1.0.4

Fixed versions

  • 1.0.5

Solution

Upgrade to version 1.0.5 or above.

Impact 7.8 HIGH

CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-94: Improper Control of Generation of Code ('Code Injection')

Source file

pypi/ansible-vault/CVE-2017-2809.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:50 +0000.