Advisory Database
  • Advisories
  • Dependency Scanning
  1. pypi
  2. ›
  3. ansible-core
  4. ›
  5. CVE-2026-11332

CVE-2026-11332: ansible-core: Argument injection in ansible-galaxy role install leads to arbitrary code execution

June 5, 2026 (updated July 16, 2026)

A flaw was found in ansible-core. The ansible-galaxy role install command processes dependency specifications from a role’s meta/requirements.yml file. Due to improper neutralization of argument delimiters, a malicious role author can inject arbitrary git configuration flags through the src field. This allows arbitrary code execution on the machine of a user who installs the role via ansible-galaxy role install.

References

  • access.redhat.com/security/cve/CVE-2026-11332
  • bugzilla.redhat.com/show_bug.cgi?id=2485379
  • github.com/advisories/GHSA-w8p5-mx5w-cpqj
  • github.com/ansible/ansible/commit/edee59aa15abcc74d920bb3e9c3835ab8db05a2f
  • github.com/ansible/ansible/pull/87070
  • nvd.nist.gov/vuln/detail/CVE-2026-11332
  • security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-11332.json

Code Behaviors & Features

Detect and mitigate CVE-2026-11332 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.16.19-rc.1, all versions starting from 2.17.0-b.1 before 2.18.18-rc.1, all versions starting from 2.19.0-b.1 before 2.19.11-rc.1, all versions starting from 2.20.0-b.1 before 2.20.7-rc.1, all versions starting from 2.21.0-b.1 before 2.21.1-rc.1

Fixed versions

  • 2.16.19-rc.1
  • 2.18.18-rc.1
  • 2.19.11-rc.1
  • 2.20.7-rc.1
  • 2.21.1-rc.1

Solution

Upgrade to versions 2.16.19-rc.1, 2.18.18-rc.1, 2.19.11-rc.1, 2.20.7-rc.1, 2.21.1-rc.1 or above.

Impact 7.8 HIGH

CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-88: Improper Neutralization of Argument Delimiters in a Command ('Argument Injection')

Source file

pypi/ansible-core/CVE-2026-11332.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:42 +0000.