Advisory Database
  • Advisories
  • Dependency Scanning
  1. nuget
  2. ›
  3. TinyMCE
  4. ›
  5. CVE-2026-47761

CVE-2026-47761: TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection

June 5, 2026 (updated June 30, 2026)

Stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via crafted data-mce-* attributes, which are executed when content is rendered. Impacts users of TinyMCE with the media plugin enabled.

References

  • github.com/advisories/GHSA-vg35-5wq7-3x7w
  • github.com/tinymce/tinymce/security/advisories/GHSA-vg35-5wq7-3x7w
  • nvd.nist.gov/vuln/detail/CVE-2026-47761
  • www.tiny.cloud/docs/tinymce/7/7.9.3-release-notes/
  • www.tiny.cloud/docs/tinymce/8/8.5.1-release-notes/

Code Behaviors & Features

Detect and mitigate CVE-2026-47761 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 5.10.9, all versions starting from 6.0.0 before 7.9.3, all versions starting from 8.0.0 before 8.5.1

Fixed versions

  • 7.9.3
  • 8.5.1

Solution

Upgrade to versions 7.9.3, 8.5.1 or above.

Impact 8.7 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

nuget/TinyMCE/CVE-2026-47761.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:53 +0000.