Advisory Database
  • Advisories
  • Dependency Scanning
  1. nuget
  2. ›
  3. Scriban.Signed
  4. ›
  5. GHSA-p6q4-fgr8-vx4p

GHSA-p6q4-fgr8-vx4p: Scriban has a Stack Overflow via Nested Array Initializers That Bypass the ExpressionDepthLimit Fix

March 24, 2026 (updated July 6, 2026)

StackOverflowException via nested array initializers bypasses ExpressionDepthLimit fix (GHSA-wgh7-7m3c-fx25)

References

  • github.com/advisories/GHSA-p6q4-fgr8-vx4p
  • github.com/advisories/GHSA-wgh7-7m3c-fx25
  • github.com/scriban/scriban/security/advisories/GHSA-p6q4-fgr8-vx4p

Code Behaviors & Features

Detect and mitigate GHSA-p6q4-fgr8-vx4p with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 7.0.0

Fixed versions

  • 7.0.0

Solution

Upgrade to version 7.0.0 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-674: Uncontrolled Recursion

Source file

nuget/Scriban.Signed/GHSA-p6q4-fgr8-vx4p.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:51 +0000.