Advisory Database
  • Advisories
  • Dependency Scanning
  1. nuget
  2. ›
  3. libsnappy.redist
  4. ›
  5. CVE-2018-7577

CVE-2018-7577: Improper Input Validation

April 24, 2019 (updated April 30, 2019)

Memcpy parameter overlap in Google Snappy library, as used in Google TensorFlow, could result in a crash or read from other parts of process memory.

References

  • github.com/tensorflow/tensorflow/blob/master/tensorflow/security/advisory/tfsa-2018-005.md
  • nvd.nist.gov/vuln/detail/CVE-2018-7577

Code Behaviors & Features

Detect and mitigate CVE-2018-7577 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

Version 1.1.4

Fixed versions

  • 1.1.7

Solution

Upgrade to version 1.1.7 or above.

Impact 8.1 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

nuget/libsnappy.redist/CVE-2018-7577.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:52 +0000.