Advisory Database
  • Advisories
  • Dependency Scanning
  1. nuget
  2. ›
  3. DotNetNuke.Core
  4. ›
  5. CVE-2026-24784

CVE-2026-24784: DotNetNuke.Core has a potential XSS vulnerability in modules' header and footer

January 28, 2026 (updated February 4, 2026)

A content editor could inject scripts in module headers/footers that would run for other users.

References

  • github.com/advisories/GHSA-jjwg-4948-6wxp
  • github.com/dnnsoftware/Dnn.Platform
  • github.com/dnnsoftware/Dnn.Platform/security/advisories/GHSA-jjwg-4948-6wxp
  • nvd.nist.gov/vuln/detail/CVE-2026-24784

Code Behaviors & Features

Detect and mitigate CVE-2026-24784 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 9.0.0 before 9.13.10, all versions starting from 10.0.0 before 10.2.0

Fixed versions

  • 9.13.10
  • 10.2.0

Solution

Upgrade to versions 10.2.0, 9.13.10 or above.

Impact 6.8 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

nuget/DotNetNuke.Core/CVE-2026-24784.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:17 +0000.