Advisory Database
  • Advisories
  • Dependency Scanning
  1. nuget
  2. ›
  3. DotNetNuke.Core
  4. ›
  5. CVE-2025-59546

CVE-2025-59546: DNN Vulnerable to Stored XSS Using Backend Admin Credentials

September 23, 2025

Users that can edit modules could set a title that includes scripts.

References

  • github.com/advisories/GHSA-gj8m-5492-q98h
  • github.com/dnnsoftware/Dnn.Platform
  • github.com/dnnsoftware/Dnn.Platform/security/advisories/GHSA-gj8m-5492-q98h
  • nvd.nist.gov/vuln/detail/CVE-2025-59546

Code Behaviors & Features

Detect and mitigate CVE-2025-59546 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 10.1.0

Fixed versions

  • 10.1.0

Solution

Upgrade to version 10.1.0 or above.

Impact 2.4 LOW

CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

nuget/DotNetNuke.Core/CVE-2025-59546.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:23 +0000.