Advisory Database
  • Advisories
  • Dependency Scanning
  1. nuget
  2. ›
  3. DotNetNuke.Core
  4. ›
  5. CVE-2018-18325

CVE-2018-18325: Inadequate Encryption Strength in DotNetNuke

July 5, 2019 (updated October 22, 2025)

DNN (aka DotNetNuke) 9.2 through 9.2.2 uses a weak encryption algorithm to protect input parameters. NOTE: this issue exists because of an incomplete fix for CVE-2018-15811.

References

  • github.com/advisories/GHSA-j3g9-6fx5-gjv7
  • github.com/dnnsoftware/Dnn.Platform
  • github.com/dnnsoftware/Dnn.Platform/releases
  • nvd.nist.gov/vuln/detail/CVE-2018-18325
  • www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2018-18325
  • www.dnnsoftware.com/community/security/security-center

Code Behaviors & Features

Detect and mitigate CVE-2018-18325 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 9.3.0

Fixed versions

  • 9.3.0

Solution

Upgrade to version 9.3.0 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-326: Inadequate Encryption Strength

Source file

nuget/DotNetNuke.Core/CVE-2018-18325.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:45 +0000.