Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. xterm
  4. ›
  5. CVE-2019-0542

CVE-2019-0542: Improper Input Validation

January 9, 2019 (updated June 10, 2019)

A remote code execution vulnerability exists in Xterm.js when the component mishandles special characters, aka Xterm Remote Code Execution Vulnerability. This affects xterm.js.

References

  • www.securityfocus.com/bid/106434
  • nvd.nist.gov/vuln/detail/CVE-2019-0542

Code Behaviors & Features

Detect and mitigate CVE-2019-0542 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 3.9.1, version 3.10.0

Fixed versions

  • 3.9.2
  • 3.10.1

Solution

Upgrade to versions 3.9.2, 3.10.1 or above.

Impact 9.8 CRITICAL

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Source file

npm/xterm/CVE-2019-0542.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:50 +0000.