Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. ws
  4. ›
  5. CVE-2016-10542

CVE-2016-10542: Improper Input Validation

February 18, 2019 (updated January 8, 2021)

ws is a “simple to use, blazing fast and thoroughly tested websocket client, server and console for node.js, up-to-date against RFC-6455”. By sending an overly long websocket payload to a ws server, it is possible to crash the node process. This affects ws 1.1.0 and earlier.

References

  • github.com/advisories/GHSA-6663-c963-2gqg
  • github.com/nodejs/node/issues/7388
  • nodesecurity.io/advisories/120
  • nvd.nist.gov/vuln/detail/CVE-2016-10542
  • www.npmjs.com/advisories/120

Code Behaviors & Features

Detect and mitigate CVE-2016-10542 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.1.1

Fixed versions

  • 1.1.1

Solution

Upgrade to version 1.1.1 or above.

Impact 7.5 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

npm/ws/CVE-2016-10542.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:44 +0000.