Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. wrangler
  4. ›
  5. CVE-2026-0933

CVE-2026-0933: Wrangler affected by OS Command Injection in `wrangler pages deploy`

January 21, 2026

Summary

A command injection vulnerability (CWE-78) has been found to exist in the wrangler pages deploy command. The issue occurs because the --commit-hash parameter is passed directly to a shell command without proper validation or sanitization, allowing an attacker with control of --commit-hash to execute arbitrary commands on the system running Wrangler.

Root cause

The commitHash variable, derived from user input via the --commit-hash CLI argument, is interpolated directly into a shell command using template literals (e.g., execSync(`git show -s --format=%B ${commitHash}`)). Shell metacharacters are interpreted by the shell, enabling command execution.

Impact

This vulnerability is generally hard to exploit, as it requires --commit-hash to be attacker controlled. The vulnerability primarily affects CI/CD environments where wrangler pages deploy is used in automated pipelines and the --commit-hash parameter is populated from external, potentially untrusted sources. An attacker could exploit this to:

  • Run any shell command.
  • Exfiltrate environment variables.
  • Compromise the CI runner to install backdoors or modify build artifacts.

Mitigation

  • Wrangler v4 users are requested to upgrade to Wrangler v4.59.1 or higher.
  • Wrangler v3 users are requested to upgrade to Wrangler v3.114.17 or higher.
  • Users on Wrangler v2 (EOL) should upgrade to a supported major version.

Credits

Disclosed responsibly by kny4hacker.

References

  • github.com/advisories/GHSA-36p8-mvp6-cv38
  • github.com/cloudflare/workers-sdk
  • github.com/cloudflare/workers-sdk/commit/99b1f328a9afe181b49f1114ed47f15f6d25f0be
  • github.com/cloudflare/workers-sdk/releases/tag/wrangler%403.114.17
  • github.com/cloudflare/workers-sdk/releases/tag/wrangler%404.59.1
  • github.com/cloudflare/workers-sdk/security/advisories/GHSA-36p8-mvp6-cv38
  • nvd.nist.gov/vuln/detail/CVE-2026-0933

Code Behaviors & Features

Detect and mitigate CVE-2026-0933 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.0.15 before 3.114.17, all versions starting from 4.0.0 before 4.59.1

Fixed versions

  • 3.114.17
  • 4.59.1

Solution

Upgrade to versions 3.114.17, 4.59.1 or above.

Impact 9.9 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-78: Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')

Source file

npm/wrangler/CVE-2026-0933.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:10 +0000.