Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. wazuh
  4. ›
  5. CVE-2021-26814

CVE-2021-26814: Improper Input Validation

March 18, 2021

Wazuh API in Wazuh from to allows authenticated users to execute arbitrary code with administrative privileges via /manager/files URI. An authenticated user to the service may exploit incomplete input validation on the /manager/files API to inject arbitrary code within the API service script.

References

  • documentation.wazuh.com/4.0/release-notes/release_4_0_4.html
  • github.com/advisories/GHSA-w36g-q975-37rg
  • github.com/wazuh/wazuh/releases/tag/v4.0.4
  • nvd.nist.gov/vuln/detail/CVE-2021-26814

Code Behaviors & Features

Detect and mitigate CVE-2021-26814 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 4.0.0 up to 4.0.3

Fixed versions

  • 4.0.4

Solution

Upgrade to version 4.0.4 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation
  • CWE-78: Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')

Source file

npm/wazuh/CVE-2021-26814.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:20 +0000.