Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. vvvebjs
  4. ›
  5. CVE-2024-29271

CVE-2024-29271: VvvebJs Reflected Cross-Site Scripting (XSS) vulnerability

March 22, 2024 (updated August 29, 2024)

A reflected Cross-Site Scripting (XSS) vulnerability in VvvebJs before version 1.7.5 allows remote attackers to execute arbitrary code and obtain sensitive information via the action parameter in save.php.

References

  • github.com/advisories/GHSA-pc95-3wgm-x28p
  • github.com/givanz/VvvebJs
  • github.com/givanz/VvvebJs/commit/c0c0545b44b23acc288ef907fb498ce15b9b576e
  • github.com/givanz/VvvebJs/issues/342
  • nvd.nist.gov/vuln/detail/CVE-2024-29271

Code Behaviors & Features

Detect and mitigate CVE-2024-29271 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.7.5

Fixed versions

  • 1.7.5

Solution

Upgrade to version 1.7.5 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/vvvebjs/CVE-2024-29271.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:31 +0000.