Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. versionn
  4. ›
  5. CVE-2023-25805

CVE-2023-25805: Versionn Command Injection Vulnerability

February 22, 2023

versionn, software for changing version information across multiple files, has a command injection vulnerability in all versions prior to version 1.1.0. This issue is patched in version 1.1.0.

References

  • github.com/advisories/GHSA-fj78-2vc5-f6cm
  • github.com/commenthol/versionn/commit/2ca128823efe962b37f2698f0eb530c2b124842d
  • github.com/commenthol/versionn/security/advisories/GHSA-fj78-2vc5-f6cm
  • nvd.nist.gov/vuln/detail/CVE-2023-25805

Code Behaviors & Features

Detect and mitigate CVE-2023-25805 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.1.0

Fixed versions

  • 1.1.0

Solution

Upgrade to version 1.1.0 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Source file

npm/versionn/CVE-2023-25805.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:44 +0000.