Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. vega
  4. ›
  5. CVE-2025-27793

CVE-2025-27793: Vega vulnerable to Cross-site Scripting via RegExp.prototype[@@replace]

March 27, 2025 (updated October 31, 2025)

Calling replace with a RegExp-like pattern calls RegExp.prototype[@@replace], which can then call an attacker-controlled exec function.

References

  • github.com/advisories/GHSA-963h-3v39-3pqf
  • github.com/vega/vega
  • github.com/vega/vega/commit/694560c0aa576df8b6c5f0f7d202ac82233e6966
  • github.com/vega/vega/releases/tag/v5.32.0
  • github.com/vega/vega/security/advisories/GHSA-963h-3v39-3pqf
  • nvd.nist.gov/vuln/detail/CVE-2025-27793
  • vega.github.io/vega/usage/interpreter

Code Behaviors & Features

Detect and mitigate CVE-2025-27793 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 5.32.0

Fixed versions

  • 5.32.0

Solution

Upgrade to version 5.32.0 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
  • CWE-87: Improper Neutralization of Alternate XSS Syntax

Source file

npm/vega/CVE-2025-27793.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:35 +0000.