Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. urijs
  4. ›
  5. CVE-2022-1243

CVE-2022-1243: Improper Input Validation

April 5, 2022 (updated July 24, 2023)

CRHTLF can lead to invalid protocol extraction potentially leading to XSS in GitHub repository medialize/uri.js prior to 1.19.11.

References

  • github.com/advisories/GHSA-3vjf-82ff-p4r3
  • github.com/medialize/uri.js/commit/b0c9796aa1a95a85f40924fb18b1e5da3dc8ffae
  • huntr.dev/bounties/8c5afc47-1553-4eba-a98e-024e4cc3dfb7
  • nvd.nist.gov/vuln/detail/CVE-2022-1243

Code Behaviors & Features

Detect and mitigate CVE-2022-1243 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.19.11

Fixed versions

  • 1.19.11

Solution

Upgrade to version 1.19.11 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Source file

npm/urijs/CVE-2022-1243.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:03 +0000.